Veeam does the job

Just a quick Woohoo!

A couple of weeks ago, I decided to switch to using Linux as my main workstation (again, I used it between 2003 and 2007 as my main OS). I decided to make a backup of my Windows installation before I re-formatted everything and put Linux on my main machine - I already use it on a number of Pis and my old laptop, but I wanted it on my main Ryzen worksation as well.

What to use? We use Veeam Enterprise at work, which is specialised on VMware and Hyper-V backups. They offer a free version for individual PCs. I decided to give it a go. I made a complete backup of the whole system (3 SSDs and an HDD) onto an external drive. All went well and it even built a recovery USB stick.

I then spent the last couple of weeks trying to get Linux working properly, but it doesn’t seem to like my set-up, which is a real shame. Sleep mode didn’t work at first, so I installed the nVidia drivers for Linux, after that it worked fairly well, but locked up twice.

Bluetooth was the next problem, it would keep losing the connection to my mouse and keyboard, so I’d lose words mid sentence or the mouse would freeze.

While we are talking about freezing, despite an nVidia GTX1050ti, 32GB RAM and an 8 core/16 thread processor, every time I opened a new window, the whole desktop would freeze for a couple of seconds - very annoying when watching a video in another window! The same with desktop games (patience, minesweeper etc.), start a new game and the video would pause while the game re-drew the screen.

This is a real shame, my previous experiences with Linux have been much better and I’ve never experienced this sort of problem before. I have heard tales of Ryzen not being well supported and it could also be the nVidia drivers that were causing the problem, but, whatever, it wasn’t a nice experience.

So, today, after lunch, I decided to re-install Windows on the machine. Veeam crapped out the first time I tried to restore, but I believe that was because I was using LVM under Linux and the partition tables were a bit messed up, so I booted a Windows install CD and deleted all the partitions on all drives, then did a basic install of Windows and rebooted with the Veeam USB stick again. It recognised the drives and overwrote all the partitions with the last stand of my PC, from 3 weeks ago. Within 2 hours (~2TB of data), the PC was back up and running as if I had done a restart of my last session 3 weeks ago, no fuss, no errors, just a working system.


I didn’t actually realise that there was a free version, I’ve heard of Veeam being talked about at work but its not really my area so I was never that interested in it. Good to know of another thing that might help me out of the sewer one day - thanks!

Its always nice to have a happy ending :slight_smile: