Trying to figure out what's going on with my computer

After waiting for about a month for an RMA from Corsair, I finally received the replacement RAM this afternoon. But it seems that this is just the beginning of my issues.

Initially, it booted normally, but then I faced the following problems:

  • Windows updates failed to download, not install.
  • After using it for some time, I shut down the computer and when I turned it back on, it went to an error screen that I didn’t recognize. It attempted to boot through but failed.
  • After spending about an hour rewiring the fan/RGB controller, I managed to get the computer up and running.
  • I used the computer like normal for a few hours.
  • I installed updates, including 23H2, and the computer crashed in the middle of the update. It then restarted and completed the update.
  • When I restarted the computer again after updating the Nextcloud client, it restarted like normal, but ended up getting stuck on the post-login loading screen for over an hour. After that, something happened while I was out of the room, and the next thing I knew, it was in recovery mode. However, the menu failed to open, and it loaded Windows. When I tried to login again, it got stuck again, and now, almost two hours later, the screen is blank with what looks like the bottom of the loading circle.

That’s the gist of it, as far as I remember.

Can you please help me understand what is happening and how to fix it?

Can you share a bit of info about your build? Is it an OEM (Dell, HP, PowerSpec etc) or did you piece it together yourself?

This is an interesting leap of logic - how did you determine fan wiring was causing an issue? Was there something about the error message that indicated fans were part of the problem?

This is really not a good sign. It’s difficult to say without having more details, but I think you may end up wiping the disk and doing a fresh Windows install as the best course of action.

I built it myself a few years ago (I’ve had problems with this computer before take a look at my profile).

Would it be safe to power it down?

Also, to be clear the update ran automatically after the system crashed and the system booted with the update installed (after the update Sysinfo said 23H2 was the version running).

Ended up figuring it. Quad channel RAM.

Do a memtest. Any time you change a processor or memory, run a memtest. Make sure it passes. I normally let a new build run for a day or at least overnight.

Based on the version number he put above, he’s running Windows 11, so he could at least easily run the Windows Memory Diagnostic.

Windows Run Memory Diagnostics

If you wish to run Windows Memory Diagnostics Tool on-demand, do the following:

Open Control Panel and type ‘ memory ‘ in the search bar.
Click on ‘Diagnose computer memory problems’ to open it.

Alternatively, you can also type ‘ mdsched ‘ in Start search and hit Enter to open it.
Choose between two options for when to run the Memory Diagnostics Tool.
You can Restart now and check for problems

I’m not willing to make the assumption that something isn’t wrong with their Windows install and I’d prefer to start at the metal and work up. Check the memory with a non-Windows dependent tool. Also, I don’t trust Microsoft software because of decades of experience.

The system works when memory is in dual channel (I’m using the computer now). I’ve also tried running the system with different pairs of DIMMs.

Also, here’s a link to the build on PCPartPicker

I reinstalled the other 2 DIMMs and was gonna rum memtest but the computer posted before I could remember what button to press for the boot menu but I was able to get it into the Windows Memory Diagnostic:

Update 2023-11-22T18:59:00Z:

The diagnostic process appeared to be completed a few minutes ago. Here’s what’s happened since:

  • After completion, the screen went into recovery mode with an error message appeared indicating that the NTFS driver was missing
  • The system restarted, and another recovery screen appeared with an error message regarding the ntosknrl driver
  • After another restart, the system either went to the login screen or the lock screen but then bluescreened
  • The system appeared to reboot normally, but upon logging in, I received error messages indicating that some programs, such as “cmd,” were not starting correctly.

2023-11-22T19:37:00Z: running memtest 7036 errors on first pass. How many passes should I run (or does it stop automatically)?

~ 2023-11-22T20:46:00Z: It just finished the 2nd pass and end with over 30,000 errors. After stopping it the system restarted and all I see is these spinning dots (almost like little loading symbols):

Any errors is too many. memtest86 runs until you stop it.

I’ve now run memtest on the pairs of DIMMs that were in the primary and secondary slots separately and both came up with not errors.

Are your memory sticks matched? It can be the case, especially with older AMD motherboards (the 1xxx and 2xxx generation in particular) where memory mismatches can be problematic. Also, some memory is sold as faster speeds, bit requires more power to reach those speeds, and the AMD version of XMP (DOCS or whatever it’s called) is not as good at getting all that right. I would recommend you check for new firmware for your motherboard and then reset the settings, and not try any memory overclock… and see if you can reach stability first.

1 Like

Yeah they’re all the same kit. Could it be the other 2 slots?

I noticed that many errors I mentioned getting on login were from reg.exe. So it seems like Windows is borked so I’m running a cloud reinstall.

Reinstalled Windows, I’m not getting those errors when I login. What should I do next?

Run memtest until you don’t get any errors for hours. Until then, your hardware isn’t reliable and no OS can be expected to run stabily.

I relaized I never gave an update, I ran memtest for something like 9 hours right after my last post but seemed to still be getting errors. Could it be a problem with the motherboard or the CPU itself (as I mentioned earlier in the thread memtest doesn’t give any errors when I run any combination of 2 DIMMs from the kit and only get errors when running all 4)? Also, XMP is disabled.

Would memtest actually fix things?

I actually updated the motherboard firmware when I was troubleshooting as part of the RMA process so the firmware should be up to date.

Can we step back a bit? What kind of CPU/MB do you have and what type of memory/speed? If it’s a dual channel processor, putting in two DIMMs/channel almost always has a lower maximum speed rating than populating a single DIMM. You may be running them at the rated speed for one DIMM/channel, but that may be beyond what they can do with two DIMMs/channel. It can also matter how many rank they are.

Nope. If you don’t know what you did to fix something, you didn’t fix it.

Last night, I ran a memory test on the DIMMs in the opposite slots and it passed. Then, I added the other two DIMMs and ran memtest again with all four DIMMs in place. Unfortunately, I fell asleep before stopping the test. This morning, I discovered that memtest had frozen about 3 hours into its fourth pass. I restarted the computer and started memtest again, but after a few minutes, the system crashed. It rebooted, I missed the BIOS menu and was greeted with a Windows recovery error screen. The computer successfully rebooted and I was able to start memtest, it’s currently running & has completed 35% of the test #9.

Ok, that’s what I thought. Does memtest store a record of past tests somewhere?

No, it does not. I grab my cell phone and take a photo when I want a record. There may be a way to get it to log the errors, but I’ve not looked into that.