Roku app not listing show episodes - could it be a regional or ISP issue?

Hi Folks

The TWiT app on my Roku stopped working a couple of days ago. Once it loads, the main show list appears as normal (and the ‘album art’ is all showing okay) but when I select one of them from that main list, it no longer shows the list of available episodes. It does show the screen for them, along with the expected options along the top (e.g. ‘Security Now Video’ and ‘Security Now Audio’) but below that is a blue screen, empty but for the word ‘Retrieving…’.

To be honest, I only use the Roku for TWiT shows (I regularly follow several TWiT shows per week) so to check it likely wasn’t a fault with the Roku, I installed the AmateurLogic.TV app (which would appear to be of a broadly similar style of app to the TWiT one) and that does work okay. Incidentally, unlike with the TWiT app, the Amateur Logic one is a single show app, so it immediately launches into the list of episodes - so it’s not of quite the same design - but the episodes are all showing and after one has been selected, it does play the video stream okay.

As the forum doesn’t appear to be flooding with posts about Roku’s not working, I’m assuming it isn’t a global problem with the Shiftkey app, so I’m now wondering if it might be a regional issue (I’m in the UK) or even an ISP related issue (I’m using Sky for broadband) and thus I’m wondering if any other UK Roku users have tried viewing TWiT shows over the past two days?

All the best,

NB I do have YouTube on the TV and the TWiT shows work when using that, so all is not lost, but the inserted adverts are somewhat irritating (to say the least)!

Edit: After lunch, I’ll Wireshark it and see where (or if) it’s calling out to get the episodes (and see if there’s any response) then I’ll post back.

Interestingly, the TWiT Live uStream still worked (but that was the only one) so I performed a packet capture in my firewall (Sophos UTM) and the exchanges all looked reasonable.

There were some TCP exchanges between myself and

A few DNS queerie for with the below response:

29 0.164326 DNS 390 Standard query response 0x1f52 A CNAME A A A A NS NS NS NS NS NS NS NS NS NS NS NS NS

I do use country blocking and I wondered if was a Russian based server, but there were no GEOIP logs and in any case, I disabled country blocking and it didn’t change anything.

So with that being dismissed, I carried on looking at the captures and all was looking reasonable until the below:

58 0.231344 TLSv1.2 75 Alert (Level: Fatal, Description: Unknown CA)

That’s quite interesting!


PS Yes, I do have Sophos UTM set to decrypt and scan HTTPS traffic (with myself being installed as a CA on all the machines) but only on my ‘private’ subnet. As you can’t install CAs on things like Android TVs, Roku’s, Sky boxes, etc, the subnet with my Roku and TV does not have HTTPS inspection enabled (it’s set to URL filtering only). In any case, this only started 2 or 3 days ago (and I was watching TWiT shows every day until it broke) and I’ve not changed any firewall settings for a couple of weeks (and none would have impacted the sub-network on which the Roku and TV resides.

Are you referring to the app that was discontinued in 2017 that was written by a third party?

The reason people aren’t flooding the forums because the app doesn’t work is that it is known that it is no longer supported.

And this post:

1 Like

Hi AaronK

When doing a Google search, I did spot a link about the Roku App retiring, but with that being way back in 2017 (and as the app was working until about Thursday this week) I didn’t look at it; I assumed that either the original decision had been reversed or that the current App was a replacement for one that had been dropped. However, I’ll now go read the thread you’ve noted and find out the full story.

Looking at my packet capture and seeing the CA error, it maybe explains what’s happened (perhaps the natural expiry of a cert associated with the App, or the App designer using a CA that’s now gone) but thanks for getting back to me and I’ll quit trying to debug the system!

Darned shame though as that was my sole reason for buying the Roku and with that now broken, it means having to put up with these goofy Google adverts (obviously, I don’t at all mind the TWiT sponsor adverts, but I’m not happy about Google inserting adverts for random garbage into the programmes).

Anyhow, thank you once again for getting back to me.
Kind regards,

PS Anyone want to buy a Roku (one careful owner)? :wink: :smiley:

Having the same problem on the roku app just says retrieving app was made by swiftkey.If I can’t get it on the roku will just have to quit watching

Deleted that app reinstalled it and still doesn’t work. We’ll be fun while it worked good by

Closing this thread since it’s also being discussed here: TWiT on Roku? Alternative?