Linux noob with a problem

Hey guys hoping someone might be able to help me out here.

Recently bought this laptop.

I have been running Linux Mint on a few older machines and was really looking forward to trying it on a new machine. I have had some issues where I get Cinnamon installed and running well for a little bit but then seemingly randomly locks up. I am able to reset it by holding the power button in. Once this happens it seems to then happen each time I try to open Chrome. I have reinstalled several times a few times tried Chromium instead but keep coming up with the same results. The most recent time tonight it happened running Chromium I rebooted and it locked up when I opened it again. When I rebooted I opened the software center and installed Firefox. I was then able to use that to download Chrome since it isn’t in the default repository. Opened Chrome and found it locked up right when I attempted to log in.

I have used mint enough to use it and know my way around but I don’t know how to look into logs or what I should do to try and figure out why this might be happening.

1 Like

You need to classify the problem… so my proposal, in the form of a joke:

You: Doctor, it hurts when I do this.
Doctor: Ok, don’t do that.

If Chrome[ium] is not working for you, but Firefox works, stick with Firefox for now? Wait and see if it remains stable. If it doesn’t, it is likely the PC hardware. If it does, then it is likely the Chrome software.


Sounds like it might me a corrupt installer. Maybe Download a few distros to try I use KDE NEON and Debian mostly

1 Like

And remember dual booting can be tricky and or problematic ( Grub doesn’t play well with Windows 10 & UEFi) I suggest going all the way linux .

Make sure to use the 64bit install isos

This makes sense. Really just hoping to get chrome working since I don’t care for Firefox much. There are times where when it boots up I can run it with chrome just fine and nothing will happen. If I reboot though a lot of the time the problem comes back.

AHH its the Ryzen Try KDE Neon I bet it works

1 Like

I have thought about trying some other distros just hadn’t really landed on anything that peaked my interest like Mint. I am do think I want to stick with a Debian based system.

only some Distros work with Ryzen 64bit one

Probably won’t be able to try it until tomorrow but I will take a look.

Thanks a lot for the tip.

No Sweat! I use KDE Neon on my Ryzen Pc works for me

here are some Tools you can use to make USB installers with or

1 Like

Remember that with Linux, you can pretty much add on any window manager no matter what the distro and get it working how you like it. Even the package manager - if you like a certain package manager, install that instead.


Hey there, is it a browser issue?
Does it happen with other apps?
This type of instability is pretty common when your graphics card drivers are not great.
Try to identify it it happens only with specific apps or if it is a global issue. That will allow you to narrow down the root cause.
If it is an app you can try alternatives or disable the feature that is causing the issue. If it is the grahics card they you can try using other versions of the driver and see if it makes a difference.

1 Like

My suggestion would be the same as for Windows:

  1. try like crazy to get it to lock up
  2. become successful
  3. note time
  4. turn off
  5. have a celebratory cup of tea, take 5 minutes
  6. turn back on
  7. look at the logs

In linux, you’d be looking at the files in /var/log, starting with /var/log/syslog . Check if something threw an error or what was last before you power cycled. The tea is important to make sure you can identify the time gap between locking up and powercycling. Whatever you do, don’t skip the tea. It’s easier for reading logs. :slight_smile:

“Read logs” : enter sudo tail -n 100 /var/log/syslog into a terminal window, maybe increase the amount of lines if this does not cover the timestamp your lock-up occurred in

sudo - you need root access for syslog
tail - reads files, but from the end (cat starts from top)
-n 100 - reads 100 last lines
/var/log/syslog - the file, check out others, too if it seems interesting

PS: IMHO don’t change distros or desktop managers simply because something freaks from time to time. As I’ve grown to know and love linux, something freaking out is part of the fun. If you changed software every time, it would be like moving apartments because it rained once.

Bets: 10 imaginary dollars on a driver, 5 imaginary dollars on keychain

1 Like

Its best to shop around and find the distro that works the best with your hardware. And make sure to check the integrity of the install ISO

Check if you have the amd64-microcode package installed, if not there, then install it and reboot to load the firmware, then try Chrome again.

I tried the kde everything seemed to be good through the install. Shut it down and when I came back and it is locking up after logging in and the desktop loading.

Going to try install mint again and try some of these other suggestions.

I’d run a memory test on the hardware.