Catalina Firefox Issue

When I updated my iMac to Catalina, I began having issues with Firefox Quantum. I couldn’t get it to work at all. It would open, but when I tried to open anything IN Firefox, it just processed and processed, with nothing happening. I looked “under the hood” a bit to no avail. As a last resort, I restarted the Mac. Through some kind of magic, Firefox began to work. It worked all day.

Next day, same thing happened. Again, I restarted my computer, and Firefox worked again.

This is now a daily chore. Obviously, it’s a pain. Does anyone have any thought on why this might be happening, or any thoughts on a fix? Firefox is up-to-date.

Thanks in advance!

Now that is odd - I haven’t noticed any issues with Firefox on any of my three Macs running Catalina.

Sounds like it might be a memory leak. How much RAM do you have?

(I was wondering why it smelled like Patchouli in here.)

I have 8 GB of RAM on this machine. It’s a 2017 21’ Retina 4K. Not experiencing any problems when I use Safari.

No idea then. I’m writing this on my MacBook Air in Firefox 69.0.2 - no problems at all. I live in it all evening.

1 Like

Thanks Leo. Once it works, it’s fine. I’ll see if the restart situation continues. I’m not married to Firefox, but I’ve been using it since Quantum was in beta.

Thanks for taking the time! And thanks for all your programming! :sunglasses:

1 Like

Firefox has some sort of a recovery mode I think or a cleanup option if you let it go idle for too long. So backup your bookmarks, and try resetting it to fresh or uninstall/install (i.e. reinstall) it.

1 Like

Thanks. I’m going to give that a try when I get a chance!