iPad OS replies broken

I tap the appropriate Reply button but half the time even though the draft shows it as a reply to that person with their picture and everything, when I submit it, it posts to the main thread instead.

1 Like

This is the way discourse works. It’s not threaded… there is only one thread per topic.

You should be able to select a portion of the person’s content (as you would select any text for copy/paste) and then there should be a way to quote it. This will help with things feeling “connected”.

It’s flat, yes, but it still shows to whom a given message is in reply, when it works.

Edit: sure enough, it shows this message as not in reply to yours, even though I tapped the Reply button from your message and while I’m editing it it shows that it’s a reply to you, @PHolder . I’ve done exactly the same procedure and sometimes had it work properly, where in the top-right corner it displays a curved arrow icon and the userpic of the account to whose message it was in reply.

Well if you’re replying to a message which is already at the bottom, I don’t think it will let you make it a reply like you expect. This is a “feature.” It is assumed (without quoting) that any given reply at the bottom applies to the message directly above, I assume. Try quoting something from higher up in this chain and see if that works better?

(Perhaps there is a bug, I’m not using that client so all I can do is try and help you understand how it is [mal]functioning…)

1 Like

Testing reply to earlier message… (thanks for the suggestion; making message long enough to be accepted to post)

Edit: huzzah! You seem to be correct! That’s fine, then. Perhaps I’ll delete this thread. Thanks!

1 Like

On an iPhone. Replying directly to you.

Ghaah! And it worked! (Does this…?)

Wait, I think canuck’s post was why yours did, @Leo. Or did you mean him?

Nope. It doesn’t work on my iPad either. Trying it out on my Macbook.

Remember hitting the reply icon in the message makes it a reply to that message. Hitting the Reply button at the end of the thread responds to the thread.

1 Like

That’s what I thought it should be doing :thinking:

1 Like

I’ll try it on the iPad when I get back to the ship. Touring Oman at the moment. Anyone want me to pick up some frankincense?


I have my sources from there already, actually! Mixing my own bodycare from pure essential oils is a hobby of mine. Enjoy your vacation and thanks for trying some troubleshooting :sweat_smile:

I’m experiencing the same issue on both iPad and Macbook when trying to reply to a specific message in the message. Sometimes it works, sometimes it doesn’t. (That time it worked, so maybe it just won’t reply to the individual if it’s the last post in the thread, as mentioned above. It’s kind of a weird quirk, but oh well…)

1 Like

You’re not the first to find it confusing it appears, but it also appears to be quite deliberate.

Edit: And I just tested this myself. I clicked reply on the item above by @baldycanuck and it showed his icon in my reply as I composed it, but it doesn’t continue to show visibly in the stream, as it is directed to the message directly above.

1 Like

The issue is with messages not in reply to the latest. I can accept that messages replying to the latest message won’t show the reply icons in the upper-right, but even replies to earlier messages don’t always (but sometimes do).

1 Like

Testing reply to @baldycanuck 's post that it doesn’t work from their iPad (which is now several posts back).

Edit: and it worked. baffled, given it hasn’t always even when replying to earlier messages

1 Like

My suggestion is always to quote a small part (highlight the text to quote then press the quote button that should appear.) This embeds like:

[quote="philodygmn, post:17, topic:3661"]
Testing reply

so as you can see, it clearly indicates the post to refer to (although it won’t give any special indication if it refers to the message directly above.)

Testing. This was initiated via the “Quote” pop-up you mentioned after hilighting the above text.

The problem with that is it clutters the thread considerably if anyone wanting to respond to other than the latest message must block-quote like that, to reliably indicate which message it replies to.

In fact, I would submit that the optimal functionality would be for hitting a message’s own Reply button to always include the upper-right reply icon and userpic.

Just to be clear, this is the same problem I’m experiencing…it’s hit-or-miss with replies to earlier messages for me too. (And just so everyone knows, I’m a he/him not a they, lol.)

1 Like

Thanks, canuck, for a message between this one and Holder’s last for me to re-test the same method but with that message not being the latest in the thread nor this resulting in 2 messages from me in a row.

Edit: Hah! No reply or userpic. Proof-positive. It’s a bug.

BTW, notice that for neither of my replies to that message did it work.

1 Like