Windows 10 home PC can't see other PCs on the network

I have a windows 10 home can’t see other PCs on the network. I have gone into the advanced sharing options and all options are selected correctly, no joy. The other PCs have all the options set the same and they can see the rest of the PCs.

Any ideas?

When you enter \\{IP address of remote computer} can you browse the shares? Are the computers just not appearing in the network browser?

They are not appearing in the browser at all.

But can you access the shares with the IP address?

No I can’t even see its IP address…

Can you ping the machine by name or IP address?

You have file and printer sharing switched on in network adapter properties?

No I can’t ping it at all.

Daft question, but they are on the same network? Try dropping the firewalls temporarily to see if you can get it working that way.

Yes it is switched on…

Ah yes, Windows 10 and networking… I’ve had many experiences that are difficult to understand or explain.

You didn’t say which build of Windows 10 you’re on. If it’s not current, then it could be one of the bugs that plagued the older editions. Networking has mostly worked correctly for me in 1903 and 1909, but I had lots of issues in the 2017 and 2018 editions.

The first thing to try is to log in as an administrator and check that you’re on a “Private” network. (Depending on the version of Windows, the option doesn’t even show on non-admin accounts.) Here’s how mine looks from a non-admin account in 1909 (where they finally seem to have gotten the display and ability to set the setting in the UI.)

If you have one of the older, buggier, versions of Windows 10, there is a service you may want to change.

1 Like

I will try that stuff latter…

I tried those fixes, the PC can now see its self and the shared USB printer connected to it but not the other PCs.

I am running the latest version of windows 10, it started out as a windows 7 PC about 5 years ago.

Are all the PCs Windows PCs and each configured to the same workgroup?

I find it strange that you cannot ping the other PCs unless ping packets are being blocked by the firewall. Have you tried switching the firewall off on each PC?

I’d agree, sounds like a firewall issue. This is often caused by the network being set to public rather than private as Pholder suggested.


Another outside chance, though unlikely are that the other PCs are very old and using SMB1 which Windows 10 no longer supports by default.


I’m with @LycheeMcPie and @Pommster, I’m guessing either the network is “unknown” or “public”, rather than private, or the other devices are using SMB 1.


If you are connecting over wifi check that the router wifi network setting are not set to isolate clients.


I have the opposite problem. My server appears twice on my network…

IPv4 and IPv6 per chance?