Stuck on 1909 - What's blocking the update?

My Windows 10 PC regularly attempts to upgrade to the latest version but always fails on the major feature update (minor security patches seem OK).

I’m currently still on version, 1909 so I suspect there is a blocking issue. The question is, how do I find out what is the blocker? I saw an article about old AVG and AVast antivirus, as well as Qualcomm WiFi drivers. I don’t use either antivirus program, and it’s a Dell PC with Dell WiFi drivers (though I suppose they could still be Qualcomm). Attempting to update WiFi drivers doesn’t work, as it reports as being up to date.

Any other ideas? I’m considering doing a clean reinstall, but don’t look forward to reinstalling tons of programs.

BWT, it’s a Dell XPS 8500 desktop, which is 9 years old. (!)
But honestly, there’s nothing wrong with it (other than what I’ve described) so I had not really considered a new machine. Maybe I should start thinking about that.

Have you tried downloading the Windows Media Creation Tool? Download Windows 10 Use it to make an installation USB and try upgrading that way.

1 Like

Is there something specific you are wanting in the new Updates or is this fomo? I’d caution against going around a blocker if it exist for your system. I know it can suck sometimes that we don’t have the newest version but it’s better to have a usable pc rather than a bricked PC.

Well I was on the Beta channel and just opened settings to check and see where my computer was at and it said I had a security issue that needed to be fixed for updates to work. I clicked the error, blue screened with updating for about 30 seconds then said to restart PC. Restarted and is working just fine and downloading updated for 20H2. Just thought it was odd.

There’s no simple way to figure out the blocker, this has been a topic of some exasperation on Windows Weekly in the past.

I got a Surface Laptop 3 late last year, it shipped with 1909. I didn’t get 20H2 until this week! And that’s a Microsoft product. So I wouldn’t put too much consternation into it. If you really want the latest, you can always back up and do a fresh install.

1 Like

You didn’t say but have you Googled for a solution?

FOMO? Far from it. As far as Windows 10 goes, I have no desire to get the latest version. In fact, if I could I would much rather revert to Windows 7 (or even use my old PC with XP Media Center). I honestly can’t think of a single thing about Windows 10 that I would consider an improvement over 7. Oh, wait… I guess I can use the Windows-P shortcut to quickly turn my second monitor on or off. That’s about it.

The problem is, I’ve started getting notifications stating that this version of Windows will not be supported much longer. A quick search shows that after May 11, I will not be getting any security updates. Gee, that shouldn’t be an issue should it?

1909 gets 18 months of support, so it is about to run out.

I remember a very similar situation going to 1909. My recollection is it was related to several previous update failures I hadn’t noticed.
On the Windows Update page under settings there is a place to look at update history. Check for any failed updates. Try to reinstall any you find. You may have to search for solutions for specific failed updates.

As previously stated, you can upgrade through others methods you don’t have to just do it through windows update or what it says. I would download the media creation tool from Microsoft make a USB or DVD. While you on the 1909 computer with windows up and running on the desktop. Insert the USB or DVD and and run the installer from either it will upgrade that way also, it maybe something “Windows update” is missing, this way it bypasses that. It may take longer but hey if it upgrades it to 20H2 and that’s what you want anyway since 1909 is EOL in over a month.

1 Like

With my machines (Ryzen 7 1700, HP Spectre X360 2016, Lenovo ThinkPad T480), I have always downloaded the Windows Media Creator and manually updated, either through making an ISO or directly updating. (ISO - I still ran the upgrade, I didn’t do a clean install.)

I think one time, there was a driver that wasn’t compatible, which I simply deinstalled, otherwise it has always worked fine.