Trying to setup Samba

strong textHey I’m trying to setup Samba on Linux Mint.

I can see the folder that I want to share on my Window’s 10 computer.
but when I click on it
it’s let’s me put the user name and password in.
but when I click on the login
it’s say wroung user name or password???

any help be nice



One trick to try is to put a backslash in front of the userID: \Paul
Don’t ask me why that might work, it’s black magic.

1 Like

I will keep you posted
I’m just reinstall my Linux VMware


For the username in the samba data
Linux mint username

I assume you’re trying to connect from the Linux box (using Samba) to the Windows box. In that case, the username and password would be the one for the device hosting the share… so a Windows username and password and not your Linux credentials.

1 Like

Trying to from my windows computer to the samba folder share

OH! In that case, I have no idea. I’ve never configured samba as a server on my own, I’ve always used a distro set to do that, like the Synology NAS. Does this help:

1 Like

You may also want a distribution focused on this purpose? If so, maybe try this:

1 Like

Here’s my Samba Conf

Adrian’s share

path = /your-share-folder
read only = no
guest ok = no
browsable = yes
writable =yes
force user = \chris

Torrent’s share

[Torrent’s Server Test]
comment = Torrent’s Test Server
path = /home/chris/Torrent’s Server
read only = no
guest ok = no
browsable = yes
writable =yes
force user = \chris

The top one is from a website I copy and paste

The bottom one is what I was hoping to use

1 Like

The \ trick was when I thought you were logging into a Windows PC. I doubt it works on Samba on Linux, so I’d remove that.

Remove the /before username

In a config file a \ is frequently and escape char. So it might not be harmful, but it’s definitely unnecessary and might actually cause a problem.
force user = chris

Did you set the password for user chris? Can you log into a terminal shell (csh, bash or whatever) or with SSH using that user ID?


Also the space in the path is a definite problem. I’d change that to
path = /home/chris/Torrent’sServer


I will try again tomorrow

I’m a newbie with Linux mint

Can you please send me a sample of what samba conf.file should look like please
Thanks for your time and help

So you need to create the user account in the Linux OS. You should be able to log into it. (There are ways to disable the login later if you don’t want that, but for now, get that working first. This way you know the userID and password is good.)
Then use the command smbpasswd to set the password: smbpasswd -a chris
then apparently you need to make sure the account is enabled: smbpasswd -e chris

Also, your Windows network, is it in a Workgroup? The default workgroup is WORKGROUP. This is the Samba default as well, but if you use something else, you’ll need to configure that. (I prefer to use HOME for example.)
In order for all the devices to see each other, they need to all be in the same workgroup or domain. (You only would have a domain if you had a Windows Server, and I doubt you’ve got that going on.)


I’d also avoid the apostrophe.

But it is good advice, check the user works at all, with logging on locally to the Mint box with it or over SSH.

I’d also go to the folder with the user and see if I can see the folder locally and whether I can open files and create files.

I’m assuming the user Chris is set up correctly on the Mint box and that it has the rights to look at the shared directory.

Edit: smbpasswd -ae chris should add and enable it in one go, although I haven’t tried that - I haven’t added a user to Samba in a while.

You are also correct, he need to ensure the workgroup settings are the same on both devices.

A useful hint, if the username and password are the same on both devices (Linux and Windows), Windows won’t prompt for a password when you try and connect.

I’m trying to setup the wizard for Linux mint filesharing to setup this folder called Torrent’s Server

Here are some pictures of the setup

Here’s is what it is saying on windows 10 when I try to log in

When ever I try to input my username and password

Not letting me log in to Linux mint share folder

I’m a newbie to Linux mint

Any help would be greatly appreciated


So at the last picture is were you get the wrong user name or password error?
The Samba service uses it own users and passwords, so you have to make one with the smbpasswd command:
smbpasswd -a chris
-a will add a user, -x remove.