Playback problems

Hi Leo
There seems to be a problem with ALL the ARCHIVE videos on your website
So far I have tried /WW, SN, TWIT and all I get is the same error:
This video file cannot be played.(Error Code: 224003)
Only the LIVE feed video works. All other archived Video/Audio streams give the above error.
Youtube and other video streams are working fine. Only your streams, both Video and Audio.

I have tried it on my main computer using Firefox, Edge and Chrome.
I have tried it on my lWindows laptops (3)
I have tried it on my iPhone

All give the same error. This happens for the AUDIO streams as well.

And Audio below:

Please fix ASAP as I have not been able to catch up on my shows.

You presumably have some sort of Ad/DNS blocking going on. You’re going to have to make changes in your configuration.

1 Like

I tried whitelisting the site in my ad blocker in Firefox. But I have no adblocker or such in my chrome and edge browsers and certainly not on my Safari on my iPhone.
Also I am using the TWIT iPhone app from Craig Mullaney and same problem there. No audio and video like I tried for Windows weekly and Security now. Only the live stream works.

Well no one else has reported the issue, so I suspect it is something peculiar to your site/configuration.

Do you use a PiHole or NextDNS or any network wide ad blocking? You need to whitelist 4 sites total, as mentioned in Leo’s post.

I use DNS over HTTPS system wide. Otherwise On Firefox I use ADBLOCKPLUS and Popupblocker from
But I have added the 4 sites to these two addons in Firefox.

Can you please try the video stream fro WindowsWeekly :

Also I just now tried the AUDIO stream from the latest MacBreakWeekly & IOS TODAY and they work just fine, yet the AUDIO for Security Now and ThisWEEK IN TECH both come up with the error as in my first post. The video of course does not work.

Therefore it cannot be that there is anything blocking my side as if that were so then it would block ALL sites.

As I said, it’s only you reporting a problem, it works fine for me (and no doubt millions of others, or there would be many complaints.) Something in your path between your PC and the network is blocking the download tracking of the podcast. It could be that those specific episodes are using a Megaphone ad insert, and that is being blocked somehow in your configuration. Who is your DNS provider that you are using with DoH?

Yup using systemwide DOH by Cloudflare. Never had a problem like this before.Twit always worked.
There is no systemwide blocker though and funny why the TWIT iphone app always worked before till now.

Another thing - I tried to download the MP3 file from - and this redirects and I get this message


Cannot download this file.
Cannot find server


and when I paste into the browser I get:

Hmm. We’re having trouble finding that site.

We can’t connect to the server at

If that address is correct, here are three other things you can try:

  • Try again later.*
  • Check your network connection.*
  • If you are connected but behind a firewall, check that Firefox has permission to access the Web.*
    Dont know what is going on here.

Yup. Thats it. Somehow or other and .net is being blocked.

The AUDIO for SecurityNow is :
and does not work for me

The audio for MacBreakWeekky is:
and this works because it is not

Wonder what’s going on

Try using instead. (It’s what I use.) DoH with Quad9 DNS Servers | Quad9

Thanks mate. I will try it.

The TWiT iphone app by Craig Mullaney is very old and hasn’t been updated in years. (Craig is still an active member of the community @Houdini7 but his current job prohibits side projects.)

But that doesn’t explain your other problems. Not sure what’s going on.

There seems to be something between Cloudflare which I use as my DNS systemwide - and and
As soon as I switch to as my DNS server I am able to download and listen to SecurityNow and other shows which I was not able to do.
As I mentioned above while my DNS is any files both video & Audio that are located on @PHolder uggestion of using works for Cachefly so thats what I’ll have to use now.

And I know that the TWIT app is old but there is no other alternative like it. It deals specifically with TWIT both archived and while I also have ENTALE as suggested by you some time ago, it does not have the live option. Any app suggestions?

1 Like

Someone recently created a new app. If you look at the Roku threads here, you will find it.

I use an iPhone so any Roku app is not going to work for me. Thanks anyway.

Yeah. Thanks. That works for me.

I understand. But the author of the new IOS app posted it on the Roku app threads.
Here is the thread: TWiT on Roku? Alternative? - Feedback - TWiT.Community

Go to post 39 for the link to the new IOS app.

Yup. I see it. Requires iOS 13 and I have an iPhone 6+ with iOS 12.x.x , also Twit broadcasts are free and this app wants $60 per year?

Thanks anyway.

Sorry, didn’t realize there was a charge for the app. I don’t have IOS…