Hibernation Issues in Windows

Hey Twit Community. I’m having some problems with my Hp Pavillion laptop. It’s a beats special edition notebook. I don’t know that it really matters but just in case it does. Anyways in Windows 7 and even when Windows 10 first came out to the the masses when I’d hibernate my computer it would turn off and remain off until a time in which I opened it up again. As of lately only 2 out of every 10 hibernations I put the system into actually keep the system in a hibernated mode. I’m currently staying with my mother so my desk is also my nightstand so it really close. What do you all think might be causing it to randomly wake up so much. Last night I hibernated my computer twice before it actually hibernated. When I used it briefly this morning and when hibernated before going into my office when I got home from the office it was on again. I don’t use my laptop for my day job so I know it wasn’t trying to access anything off it.

Any suggestions on how to fix this issue as its becoming super annoying. Thanks in advance.

AHA!! I have fought this battle with many PCs and mostly won. So much so that I have a standard sort of post that I have sent to others on Reddit to try and help them. I will go track down a copy of that from my archive (I don’t use Reddit much) but here’s some suggestions.

First and foremost, you can ask Windows to help you out a bit. There is a command that will tell you the reason why the computer last woke up. The next time it happens, from a CMD window (press and release the Windows key, then type in CMD and press enter) try powercfg -lastwake Here’s an output from my PC that I am using as I type this:

powercfg -lastwake
Wake History Count - 1
Wake History [0]
Wake Source Count - 1
Wake Source [0]
Type: Device
Instance Path: PCI\VEN_8086&DEV_9C31&SUBSYS_50041458&REV_04\3&11583659&0&A0
Friendly Name: Intel® USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)
Description: USB xHCI Compliant Host Controller
Manufacturer: Generic USB xHCI Host Controller

That long PCI name can sometimes be decoded by Google if you get something similar and don’t recognize it, or maybe sub-parts may resolve to give you a clue.

While you’re in the CMD window check what devices are armed to wake the PC, here’s output from my PC:

powercfg -devicequery wake_armed
HID Keyboard Device

In any case, the three most common things to wake your PC are:

  • mouse (you or your cat bumps it, or vibrations move the table or something)
  • wake on lan (yes, even from WiFi, and yes this can be busier/noiser than you’d expect)
  • the system/windows “should I do maintenance now” timer

Tackle these one at a time so as to maybe have a chance to know what fixed it.

The mouse is easiest. Go into Device Manager (with elevation to admin), press and release Windows-X and then hold down shift and CTRL as you click on its name, it should prompt for the admin password. It’s important that you do this with admin, or else you WILL NOT be shown the “Power Management” tab that you need. Find your mouse, and right click on it and select properties, then go to the Power Management tab. Uncheck the box “allow this device to wake the computer”

The network should be done similarly. It could be trickier if HP has some special software/driver for it… but you’re looking for “Wake on LAN” although it may have other “branding”.

The windows high precision timer or whatever is a real pain in the a**. Let’s hope you don’t need to fight with this one. I had that on one machine and I fought for weeks to finally find a way to disable it. If you need this option this link may help https://www.howtogeek.com/122954/how-to-prevent-your-computer-from-waking-up-accidentally/ search for “Disable Wake Timers and Scheduled Tasks”.

Good luck!


So according to the last wake it was my window update. Went to task scheduler but doesn’t show any update processes that are elevated to wake computer up to run this task.

Did you try the other things in the howtogeek article ? Wake timers etc have solved these things for me in the past.

I did and still had issue. Did a PC refresh today so I could keep my files where I left them and so far seems to have been the only thing to fix it. Google updated seemed like the likely culprit so I didn’t install chrome after the reset.

1 Like

I have never trusted these types of modes on a computer. While it is a pain to wait - on a Windows laptop, I always just turn the thing all the way off, and then all the way back on.

1 Like

I primarily use hibernation not as a way to load windows faster but simply as a way to turn my computer off so that it doesn’t use battery power, but allows me to pick up where I left off. The one thing I don’t like about shutting down windows everytime I use it is that I have to launch the same 10 windows when I log back on. I guess maybe that’s what you mean. But thats why I don’t do it that way.

1 Like

Yes, that is what I mean.

Going back years, Windows used to not handle that well. So, I have just never tried it again.

It works fine on this low powered Intel 4010U… I only reboot it once or twice a month depending on Windows Update’s schedules for updates needing a reboot. But to be honest I don’t really rely on it working… if there is a power hit or something I wouldn’t be upset if I lost the state of the machine.

1 Like

Oh that’s not why it annoys me. If it restarts that’s fine. It annoyed me because in my current living arrangement its right next to bed. I’d hear the fans kick on which is how I knew it was running. If it wasn’t for the pesky fan noise I honestly wouldn’t care if it was on 24/7.

1 Like

Are you on the 1909 release? If so, it might be related to the wake-up problem described here:

This is the problem I had with my one machine that first ever had Windows 8 OEM installed directly on it that then got upgraded to Windows 10. It took me a long time to figure out what was causing the issue and how to disable the task causing the problem. I am not happy to hear that it might come back from the dead :grimacing: