'could not find this file' - unable to delete file / folder

I am having this particular issue.

image .

I have tried booting into safe mode, elevated into cmd prompt and even killed explorer.exe but the folder/file i would like to delete cannot be deleted.

Ran a virus scan, zilch, na da. I can create new folders and files in the problematic file and delete those with ease but i cannot delete said folder/file.

This is a Windows 10 unit. And no, i am unable to unplug the hard drive and place it on a different computer to delete it from there.


Those individual files, i am unable to rename them


affected folders i can rename them but not delete them

It’s possible the filenames have unusual/invalid characters? Try bringing up a CMD window and go to the folder with the CD command. The use the DIR command to see what is there and the DEL command with the filename in quotes… so something like DEL “My Invalid @ Filename”

1 Like

when i try to delete the folder. Same issue with sub folders.

when i try to delete the Icon file

Now when i check the folder property, it gives me this


The icon file property is this.


And no, i cannot change the file name nor can i remove the read-only attribute.

Googling on this gives a lot of answers, but not many of them seem relevant to a situation like yours. I guess you could try running ChkDSK on the drive. (Go to the drive’s properties and look for the tab Tools and check for errors.)

sadly the tools from properties and cmd chkdsk did not find any issue with the drive.

Unsure where else to go with your issue. It’s hard to know what could be “wrong” with the files without knowing more of the history. I guess you could check through the SysInternals tools and see if any of them spark an idea:

I’m curious who does it show is the files owner?
Also is the file read only? Have you tried changing that?
As admin Tried DEL using the full path including file extension?
As admin Run sfc /scannow then reboot and try again.
Have you seen this? How to Fix the System Cannot Find the File Specified - EaseUS

icon file does not show any owner. Also it is not on read-only.


For the folder it is read only and i am the owner. I cannot remove the read-only as it gives me the error of The system cannot find the file specified.

sfc scannow done and it mentioned corrupt file found and repaired. Reboot done. still same error.

link does not help as i am not accessing the file/folder. i am trying to delete it.