Windows Server 2022 setup WSUS


My name is Chris

I’m trying to setup WSUS services on Windows Server 2022

I’m getting this error message
I tried to setup two times same thing happen again…,

I go through the setup and everything goes through ok looks like…

When I try to download the WSUS update for windows 10 and windows 11

The error message comes up

Any help would be appreciated


This is, unfortunately, a common error that occurs frequently on every version I’ve ever used.

Usually a reboot will sort the problem out, for a while. This is just a user interface problem, generally (UI can’t access the database).

Why Microsoft, after nearly 20 years, still can’t sort this out, I don’t know.

I use the task manger to see if the updates are being downloaded.

I noticed you haven’t named the server, is it possible you also haven’t activated it yet? I’ve never tried configuring WSUS on a system that wasn’t activated, perhaps that could block it.


I activated the windows server 2022
But I didn’t not rename the server yet

I will try again later today when I get home from work around 6pm

To reinstall the windows server 2022


If the error message comes up again I will try to reboot the server

The server is network connected to my router


I know it’s been a while since I posted something

But I’m having trouble with windows server 2022 wsus

I got the workgroup working for my two other desktop computers and laptop computers

But every time I try to setup wsus the same error message comes up

Any help would be appreciated