Weird glitch when plugging in external drive "application not found"

Hello guys,

Whenever I plug in a usb drive or external hard drive a pop up on windows explorer will say “application not found” but the usb drive/external hard drive will still work. It’s annoying glitch, I don’t know what causes it. I read some other forums on the internet and tried their troubleshooting advice but none of it worked.

You didn’t mention which version of Windows you’re using, or whether you are up to date with your Windows Updates. In any case, this is unlikely to be easy to diagnose without more info, and even then it may still be hard to diagnose. You need something in the error message to help point one into a direction for further investigation. You could try running the Windows Reliability History and see if anything looks suspect. You could also dig through the Windows Event Viewer and see if anything stands out.

Failing at finding the culprit, the best advice is to do a backup and then reset your Windows install to a fresh install.

I’m guessing you’ll get the same suggestions from this forum :slightly_smiling_face:

But it sounds like autoplay has an application defined for that device, and the app is missing or corrupted. Do you see anything if you look at the autoplay setting (right click on the drive I think).

Or you can turn it off completely in Windows settings as a test.

2 Likes