LastPass issues today?

Is anybody else having LastPass issues? All day I’ve been unable to save any new passwords or changes up to LastPass. It just says something like ‘it’s taking longer than expected’ then gives up.

The status page is all green, I can access my vault via the web as normal, it just won’t save any edits via the Mac Firefox add-on?

I had the same issue yesterday. I was updating the password for a site and it would not save in FFX/LastPass – just a circle going around. Eventually it timed out with an error. Tried several times. Also noticed it wouldn’t obey the login time-out that was set.

Seems working now though…

1 Like

Seems OK again today :+1:t2:

Some issues I’m having with LastPass recently

First- Lastpass doesn’t appear to recognise Twit.comunity login page. I’ve used LastPass for 10+ years and only time I’ve had a similar problem is with a few Aussie gov sites.

Second- I originally signed up (to TWIT Com) in Nov 2019 with Name "Trevor from Australia” or maybe that was the heading of my first post to the Intro group and assumed LastPass would save the UID & PW but hasn’t.

Third- I still get an occasional email notification from TWIT Community so the original UID is in your system.

When I tried to do a lost password your page says my actual email address is invalid.
Now I’ve signed up again with another email address just so I can get in touch, god knows if it will last.

No problems with and LastPass here. The Chrome extension recognises the web site fine, as does the iOS app.

Everything auto saved fine by LastPass and 2FA enabled too.

First I’ve had this before with Lastpass if the URL saved when it stored my credentials is different from the URL you then use to login to the site. Take a look at the entry in LastPass and see if the URL is ‘’ or something else.

Second Is this you? Username is Trevor - can you request a password change for that account? Need to decide which one to continue with now though :grinning:

1 Like

First There was no entry for in LastPass.

Second When I tried a PW change it said my email Addr was invalid and it wasn’t. I continue to get notifications in that email box - so what is happening???

Thanks for your suggestions Jamze,


1 Like

No worries.

Perhaps @PDelahanty or one of the other admins could check your original account.

When I do a “forgot password” link, it asks for my username OR email address. Maybe try entering your username and it’ll send you password reset link to the registered email. Username is Trevor from looking at your original profile.

Lastpass just has for my entry and seems to work on the web and Discourse Hub.

I seem to remember that when the community started there was a problem with and not pointing to the same location, which was corrected by some sort of behind-the-scenes update (DNS records maybe?). If the “Trevor” account was signed in to using LastPass before that change was made, I wonder if that has anything to do with LastPass not recognising the saved URL is the same as the current login URL?