Cox Gigablast/Orbi ethernet connection slow compared to desktop connection

I just upgraded to Cox Gigablast which can give me roughly 900 down and 35 up. Our desktop PC is connected to the Cox router via ethernet and we are getting roughly 600 down. BUT, when I test the speed with the Orbi ethernet connection to the Cox router via the app and we only get about 94. I would expect a lot more. Any ideas?

WiFi is just not fast, certainly not when compared to a wired link. Your wired link is not shared between anyone buy you and the router/modem, whereas your WiFi is ALWAYS shared by whatever devices you have in your network. If you have lots of IoT or other devices clogging up the airwaves (or your neighbours do) then your WiFi is going to spend more time sending retries than it will sending data. Distance also plays a part… how far (and how many walls) are between the device and the router also play a part. And also, what is the capability of the device your testing with? (A mobile phone?) Does it only do WiFi N or does it do WiFi AC?

To set your expectations for maximum speeds, this article may help… but remember the maximums are under IDEAL situations. https://www.actiontec.com/wifihelp/evolution-wi-fi-standards-look-802-11abgnac/

1 Like

Thanks, but the speedtest between Orbi and the Cox router is testing the wired/ethernet connect, NOT a wifi connection.

OH! I see. Well in that case, try a different cable between the two, to make sure it’s not a bad cable, and make sure you’re using the LAN port. Also, assuming the Cox router is doing the work, you should put the Orbi into a mode that disables the router in the Orbi (which it appears they call AP mode) https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point

Thanks. I actually changed the ethernet cable from Cat 5E to Cat 6. Got the same result.

I am thinking about the AP mode. I have a fairly complex setup (I connect a TV antenna to the Orbi satellite), etc. and I will test AP mode later once everyone has gone to bed.

I also just want to check if I lose anything other than using the Orbi app.

Not too familiar with the Orbi product, but their sales page says it features “Comprehensive anti-virus & data theft protection for your PC, Mac® and mobile devices with NETGEAR Armor” meaning it’s probably applying some measure of logic to the traffic.

I haven’t found anything specific, but any time a network appliance is messing with traffic in this manner there’s always a hit in terms of throughput. Higher end equipment will usually state the expected line rate in the tech specs with such features on/off, it’s possible Netgear chooses not to make such promises though.

Are there any options to disable security features within the Orbi? Try toggling them on/off to see if there’s a difference. Also, if you see anything about hardware offloading make sure that’s enabled.

Yes, and I have this turned off.

So here’s what I tried…I switched to AP mode, and lost my Channels DVR server. I rebooted it, and it was still gone. Also, setting to AP mode still kept my speed at around 90 down, so at this point probably not worth messing with AP mode.

I resetted my Orbi to factory default. No improvement.

I think I have tried all my options. A bit puzzled or maybe I am expecting too much.

Thanks everyone!

I just was able to pull this up. Looks like the WAN port on the Orbi is limited to 100M?? This seems odd to me since it can broadcast over Wifi potentially way more.

Here’s a person who had the same problem but found out it was his cable. I just changed my cable again to another CAT 6, and no luck.

Well ports can auto negotiate, and there are complex reasons why the negotiations don’t always succeed, but I don’t think that’s a problem here. Is it possible the Cox router has a slow port you’re connected to? Can you swap the router into the port the computer is using that is supposedly getting much faster speed. (Or alternatively, does the PC negotiate at the same fast speed if plugged into the Orbi (as in does the Orbi port speed change based on the connected device?)

Yep, I tried swapping and no change.

That was my initial thought as well. My router has 4 Gigabit ports, but 1 runs a gigabit by default, the other three run at 100mbps by default to save electricity. I had to go into the router firmware and manually change the ports I was using to run at gigabit.

1 Like

Make sure Cox actually upgraded your service to the appropriate speed. I had this problem with AT&T Fiber initially after upgrading from Uverse. It turned out that they were throttling me somewhere.

Also, try turning off any addressing the modem is doing. With AT&T, there is a SmartDMZ mode that they want you to use when you are running your own router, but the modem still does some fire walling and routing and the double-NATing makes things weird. The workaround I found from others was to open every port (1-50999) on the firewall on the modem to point to my router’s IP and I put everything behind the Orbi.

Thanks. I definitely am getting close to 1 Gbps when hardwired and around 700 when wireless from their router.

I tried having everything route through their router by putting Orbi into bridge mode. It screwed up some things I have hooked up to the satellite. I tried putting their router into bridge mode but nothing gained and that router becomes useless which didn’t make my son happy since he had his computer hooked directly to it for his gaming.