Catalina 10.15.1 Red dot on Apple ID

I have another question. I have Catalina installed on my iMac.
I have 2 accounts on my Mac. One is the Administration account and the other is my user account.
I run with the User account normally and if I need admin rights I just fill in the password when requested.
But I tried to use the same Apple ID for both accounts. Once I am log into the user account and log out and log into the admin account I get a red dot in the system preference under Apple ID. I am forced to log in again many times including giving my iPhone password. Then all is fine but if I log out and into the other account I get the same red dot under Apple ID
Is this a bug or a feature ???

1 Like

I had the same issue. For me, I did not want my iCloud account on my Mac for reasons, but I could not stand the red dot. The only fix I know is to log into each account, set up your Apple ID, and configure iCloud. Then go back into the settings and delete the iCloud account.

I have my MBA configured to boot into several different MacOS versions. I have noticed the same requirement to login to iCloud, including entering the iPhone PIN, but have not paid attention to which MacOS version asks for it. Will have to pay attention as I change versions. Didn’t consider it might be a Catalina feature.

It’s a bug - and it’s well-known. I didn’t know that; I thought it was me until I mentioned it a while ago on MacBreak Weekly and both Rene and Andy said it happened to them all the time!

The last time it happened to me I had to re-log into my iCloud account about a dozen times!! Here’s the good news, it seems to have been fixed in Catalina. At least I haven’t had that problem at all on my new MacBook Pro.


Tried to force the issue by switching between MacOS versions, but nothing happened.
Just for grins, make sure Keychain is checked under iCloud settings in System Preferences. I went so far as to uncheck it, then re-checked it.


I am using Catalina it is still not fixed 10.15.1