Is there anything good in MacOS Ventura

Wow, the old adage: “It Just Works” no longer applies to MacOS Ventura.

Jeepers…. It is so security sensitive, that it just makes me crazy. Nothing is easy anymore. Hooking up a midi keyboard has me scouring for hours looking for help. Setting up an audio interface is like landing a man on the moon.

I’m just a guy who wants to use my Mac Mini like I did with my older iMac with Catalina on it. My Mac is now just as convoluted as a PC.

Can’t they just make a regular version of MacOS for regular users not for some heads of state or nefarious souls who need to be protective of every bit of cr@p on their computers?

What a bummer, MacOS is turning into.

Having come over from Windows (again) in 2021, I find it great. At least the UI is consistent, when they refresh it.

In Windows, you still have parts of the UI dating back to the 1990s and still wearing their 1990s clothing, some things work, others don’t - on some of our PCs, the new System Settings tell you that, as the local administrator, you don’t have enough rights to make changes! The old Control Panel still works (yes, you can change most thing in both the new and old way).

The new Control Panel on the Mac is different, but at least it has all been changed in one go and it all looks like it belongs. Dark Mode is consistent, again. The use of PassKeys, sucurity keys and the better encryption of data in iCloud are all big improvements that came with Ventura.

I’m not a musician, so I can’t really comment on attaching music devices, but the external drives, keyboard and mouse “just worked”. Parallels “just worked”, connecting to and maintaining my Linux boxes “just worked”, no extra tools needed.

I’ve used Macs on-and-off for nearly 3 decades. I first used a Plus and then an SE back in the late 80s and early 90s. I bought my first Mac for home use around 2006, the first 24" iMac, using it up until Lion, when support was dropped for it. Each time I’ve come back to the Mac, it has been better than when I left it.

But, security is one of the biggest problems facing all of computing these days, so it is hardly a surprise that modern devices are more sensitive to security issues and ways in which the system can be compromised. That is one of the operating system’s primary roles, and today, probably its most important one.

Without knowing exactly what problems you are facing, it is hard to say why you are having problems, whether the OS is really at fault, or whether it is being reasonable, for the current times, and you need to adjust.

1 Like

Unfortunately change is something we’ve all got to deal with. Although the alternative is stagnation, which is worse in my mind.

You ought to call in to Ask The Tech Guys when they air ( on your mobile), or record a video question and send it in for the next show. I’m sure Leo and Mikah would be able to get you squared away.


After 10 years on her Intel MBA, my wife has just got an M1 MBA. Just upgraded to Ventura. The only thing I notice when connecting devices is an ‘are you sure’ check. Once you’ve said yes, it doesn’t appear again.

In Windows, you still have parts of the UI dating back to the 1990s

Why does MS refuse to sort this out? It’s only visuals, I know, but consistency across the OS would make it seem so much more polished (even if some of the code under the hood is decades old.)


UPDATE: It may just be Apple Silicon. I found this, which I thought is weird.

UAD Installation on Apple Silicon Macs

With Apple silicon, the additional steps below are required to enable installation of UAD and Apollo software (in addition to steps required during installation).

Start the computer in macOS Recovery

  1. Shut down the computer.
  2. Press and hold the power button on your Mac until you see “Loading startup options.”
  3. Click Options, then click Continue.
  4. If requested, enter your account password.

Set the security policy

Note: You need to keep the security policy settings below (even after UAD installation) for UAD software to function.

  1. In the Recovery app, choose Utilities > Startup Security Utility from the Menu Bar at upper left of screen…

  2. Click on the system drive you want to use to set the security policy.

  3. Click Security Policy, select the Reduced Security option, and enter your password if requested.

  4. Check the “Allow user management of kernel extensions from identified developers” option.

  5. Click OK, then restart your Mac for the changes to take effect.

Yeuch! That is horrible. It sounds like legacy software that hasn’t been updated to run on modern versions of macOS. They are using Kernel extensions, which I believe have been depricated for a while now - audio was switched from Kernel extensions to using the new OPAudioFamily with version 12.3 (Monterey).

So, it sounds like UAD and Apollo haven’t updated their software to use the current (safe) standards and require the user to compromise the safety of their machine in order to run it.

1 Like

I just switched to Ventura from Big Sur when I ‘upgraded’ from a 2014 iMac Retina to an M2 Mac mini. It has not been the smoothest of transitions. I can’t say there is anything in Ventura that I find compelling and a few things that I do not like. The new System Settings is not ideal – in fact, when I was on the phone with Apple Support about one issue the advisor had no idea where some settings were and told me to use the search bar. Time Machine does not seem as flexible. My display keeps forgetting it’s 27" and wakes from sleep as if it were a much smaller screen with all the windows shrunk to the bottom left corner. And the Books app is even worse than on Big Sur which is a remarkable achievement.
One thing I do like, and this may have been available in Monterey but I could not install it, is copy and paste across devices.
I think it would be better if Apple changed to a 2-year cycle for macOS releases and took the time to produce a fully polished product with less concern about delivering new features every year.

That is usually a sign that the monitor is too slow to wake up out of sleep mode to report to the Mac, what resolutions it supports, so the Mac drops back to the minimum… But, it being an Apple display, that surprises me!

I’ve talked to Apple about this without success. It happens with multiple ‘users’ on the mini. It is possible that the problem was caused because the first device the display was connected to was a MacBook Air. The only possible solution I’m left with is rebuilding the mini from scratch ‘by hand’, i.e., not from a Time Machine but that is too much work to contemplate and I have no idea whether it will work.