Encrypted External HDD won't Mount

I’ve been a windows guy my whole life but my wife has a 2013 MacBook pro running Mojave. I’m pretty tech savvy but ran across a problem I just can’t figure out.
I have used two different external 4tb drives to do a second backup of photos and files. One, I encrypted a 2tb volume with APFS and the other I did the entire drive as an encrypted macos journaled volume. However, after about a week or two neither will no longer mount. The password prompt appears and after typing in the password, I get a message saying wrong password. I know I’m entering in the correct password. I have tried the drive on different USB ports and on a friend’s MacBook pro.

Anyone ever had this problem or have any ideas on what to do?


Welcome to the forum, and to MacOS problems.
Don’t think any of these will be of particular value, but they are what I would try.

Anytime I get the wrong password message for a drive on my Mac, I reboot. Usually helps if I really know the password.

Since you have had the problem on both your wife’s and friends Macs, either the password is wrong or the drives are messed up. Also, because you get the password prompt to mount the drive, I don’t think the password is in your keychain, but have a look. Under Applications, keychain will be in utilities folder.

Next, you can try First Aid in Disk Utility, also in the Utility folder. Pretty worthless since they removed the Repair function but you have nothing to lose trying.

You said “second backup”. Does that mean you can try again?

1 Like

Unfortunately restarting or First Aid did not help. And no, it was not stored in the keychain. However, I know I’m using the right password because I was able to mount it several times (Probably between 5-10) before I could no longer mount it.

I have also tried 3 different cables in case the cable went bad. No luck.

I can try again. I had transfered upwards of a TB of data so there is time involved. However, the thing I really fear is it happening again and again, since it already happened twice (on two different drives.)

Does anyone know if doing an iphone photo backup to the external drive would mess anything up? We were unable to use the photos library on her computer due to a lack of storage space. So, we copied her photos app library to the external HDD and then we were able to proceed with transfering them to the harddrive.

From reading in other places. It seems likely that it could be due to it being unplugged without properly unmounting. Which did happen on accident. Could that really kill your drive?

Yes, it happened to me once on a usb drive, but using some recovery software, I can still see that the files is still on the drive but inaccessible. Haven’t got round to recover them.
Sometimes u try to unmount a ext drive, it just doesn’t do it, I just unplug it, luckily it’s still ok.

But to your more specific issue, I did encountered the same problem where an encrypted drive will not accept my password, when I know it’s correct. :man_shrugging:

If it wasn’t properly unmounted, that could very well be the problem. :frowning:

Just as a thought, your username is TexanInAsia - you didn’t happen to accidentally switch keyboard layouts between local and US did you? Probably unlikely, but it can happen - we get it all the time, German company with US subsidiary, trying to log onto the US servers with a German keyboard can drive you nuts, if you don’t notice that the server has switched the layout!

In fact, I often use the on-screen keyboard to enter the password, just to be on the safe side.

Would there be any fix for this on a Mac?

And that is a great idea that I wouldn’t have thought of but unfortunately it was the english keyboard. I even tried typing the password in a note to copy and paste it in and it still didn’t work.

Your original post said this happened on 2 different external drives. Did you unplug both before unmounting?
I keep multiple Photos libraries on external drives, but not encrypted drives.
Also, bricked a 256gb USB stick and a 1tb external drive by unplugging while mounted. Could never get them back.
I have recovered others by re-partitioning using Disk Utility, but it took multiple tries. In one case, I started Mac in Internet Recovery (command-option-r), and used Disk Utility from there to re-partition drive. Lost all data, but got the drive back.