2FA Authenticator App Issues (Last Pass)

At the risk of letting everyone know I don’t have 2FA on my accounts (I still do for some). I am having some serious issues with some of my 2FA protected accounts.

So a while back I set up my accounts that offered 2FA with Last Pass Authenticator app. It worked fine for a long time but then one day I got a new phone. I went through the accounts and removed 2FA, then re-did it all on my new phone, using Last Pass Authenticator. This is when I started to run into issues.

Namely - Twitter. The new phone/app worked fine setting it up, but it would never work again after that. Every time I try to enter the code displayed on the 2FA Last Pass app, it would say that it is incorrect. It also happened on here - my old username I cannot log into anymore because the code provided by the app is incorrect. PayPal as well.

Even after logging into the account from somewhere that did not need a 2FA code, turning off 2FA, and removing the code from the app, and retrying it, it won’t work. On Twitter, LinkedIn, and some other sites even the initial setup with a 2FA code won’t work anymore.

I have tried a different phone, Google Authenticator, Microsoft Authenticator…nothing works. Every single initial setup now for my accounts on 2FA doesn’t work (for a bunch of them at least). What the hell is going on?

So now I have 2FA disabled for most sites that don’t have an alternative. I’d like to get a Yubi Key but that doesn’t really solve my problem because only 1 or 2 of my accounts offer a physical 2FA option. The others offer SMS, but because I live overseas - that doesn’t work. So I am stuck here. I can’t use ANY form of 2 Factor other than a phone call.

Why won’t these 2FA authenticator apps work for me? The only thing I can think of is the original app, the FIRST time I set it up, is still the “correct” code. But then why after disabling the 2FA, and reenabling it, will it not work? I am totally at a loss and thought maybe I could get some insight here.

Thanks for your help everyone. I know a bunch of you use LastPass so I thought I’d throw the question out here.

Authenticator codes are timebased. Since you are having trouble with multiple Authenticator apps, I would suggest you start by checking time settings on your new phone.

From some searching, appears that Google and Authy Authenticators both have a time sync feature buried in the menu on Android, but LastPass does not.


Thanks for the suggestion. I’ll check the time settings, but can you be more specific? What should I be looking for? Making sure my time zone is the same as the app I am trying to 2FA for?

I tried the old phone, didn’t work. I tried using the code from the old phone, then tried to remove and start over with the old phone, neither worked.

Since Google and Authy have a time sync feature, not sure you can see where the problem is.

Hate to suggest it, but if the sync does not work, try creating a new account, and try using Authenticator from there.

1 Like

It worked. You’re a genius. I set my phone to auto time/date instead of manual time zone. It works now.


Nice to get it right once in a while. Stay safe.

1 Like

This has been driving me nuts for WEEKS. I’ve been searching and searching with no idea what I was even looking for.

Thank you!

1 Like

Amazing how something so simple can bring our digital devices to a screeching halt.

Hey, if you can solve why Face ID on my iPhone 11 running beta iOS stopped working, we’ll be even.

1 Like

So much is critical on timing these days…

Well done @Bgeeoz! Nice catch.

Having just rolled out soft tokens for 2fa for a project there are a surprising amount of people who don’t have the time source set to auto on their phone and had similar problems.

I thought that most people used their phones as a watch replacement so would be very sensitive to the time being wrong, but I was wrong :man_shrugging:

I live in +10ChST and I have had many problems using automatic time zone. Not entirely sure why. I think it might be because the carrier is Docomo and the routing for data goes through Japan. I had it manually set because of this.


Nicely done buddy!!!

Have to say that a place to help with “real world” device problems was and still is my main reason for wanting a TWIT community. Always feel kind of useless when listening to TTG podcast and know a solution to someone’s problem.