Using Waze and podcast app at same time?

I like to use the Waze app while I’m driving so I accidentally drift too far above the speed limit, Waze will give me a warning chirp. I also enjoy listening to podcasts when I drive. My podcast app (Overcast) will not always automatically return to play after Waze interrupts. How do people in states where it is illegal to touch your phone while driving handle this problem ?


I don’t use Waze, but when I get a notification from another app, PocketCasts just carries on playing regardless (option in settings). If the setting is disabled, PocketCasts goes quiet for a second or two, then comes back, Audible works the same, but doesn’t have an option to just continue playing at full volume.

It sounds like Waze is not giving a notification, but “playing media”?

1 Like

Waze is giving turn by turn audio. About 80 % of the time, the podcast audio will return, but for some reason it won’t always.

1 Like

Waze has a setting for integrating audio controls into the Waze screen, but support for apps is limited (Overcast not supported yet).
Settings->Voice & sound to show the audio player, then Driving Preferences->Audio player to select the support app.

1 Like

I rarely use the navigation system in my car and I don’t even have a navigation app installed on my phone.

When I do use it, I have the voice turned off, I just go by the directions shown in the instrument cluster. I think I have used the Navi maybe 3 es in the last 12 months.

1 Like

I use an offline navigator (“MapFactor Navigator” that is “stuck” on my Nexus 6P which is stuck at Android 8, and the app has been updated a number of times since I last used it, so I don’t know if what I am about to say reflects current reality.) In that app, using bluetooth audio to give directions and play music, I had a similar issue (only in my case it mostly always never resumed.) I looked into the settings of the navigation app, and there was a setting related to Bluetooth that I fiddled with, and that fixed it for me. I just tried to find it again, but the app has changed so much it no longer exists, and my current settings are at “Default” so maybe it was a workaround. Anyway, look in your settings and see if Waze has anything like that sort of setting.