Setting up Squid Proxy

Hey
My name is Chris

I’m trying to setup Proxy on Ubuntu Server

I went through the steps to install and config file

But when I setup windows 10 to use Proxy settings

I go online and the username and password not working

I’m a new bee to Linux os

Any help be great

Thanks again

Chris




Your embedded call to openssl is failing with an error about the -crypt option. I don’t know why that would occur, unless that option has changed somehow in recent versions of openssl.

I have Windows version:

C:\> openssl version
OpenSSL 1.1.1q  5 Jul 2022

on that version, for me, I can generate a password with the openssl passwd -crypt command like so:

C:\> openssl passwd -crypt foobar
PfXAS1P6vdYS2

C:\> openssl passwd -crypt foobar
Fhdgg1GSPnfsY

As you can see, each time you encode the same password, you get a different version, because it uses something called “salt”. (So you can’t just have a reverse password lookup, known as a rainbow table.)

So try just issuing the command, and see if you can get it to work alone. Once you can you could just copy the encoded password characters and replace that into the rest of the command you were trying to issue. (You could test with my “foobar” password above if you wanted.)

The other issue you have is the command you are using is just appending to the end of the file. If you have failures already, you’ve already appended multiple lines of “garbage” to the file.

How are you with the ‘vi’ editor in Linux? If you can manage it (it’s odd if you’re not familiar, there may be other choices, such as nano or pico, try them if vi is too strange for you.) In any case you need to edit the file… so try

sudo vi /etc/squid/htpasswd

and see if you can clean out any garbage you appended at the end.

Hey
Maybe someone can please send me a copy of there Proxy setup Ubuntu server so I can copy and paste it into my Ubuntu server

If I can do that

I’m looking at this guide online

I was going to ask you why you want/need a proxy to begin with, because you probably do need to have some minimal basic Linux experience before you will feel comfortable maintaining a server. (Very little of Linux maintenance can be done with a GUI I fear, it’s almost always on the command line.)

In any case, I saw your name “disney proxy” which lets me think maybe you’re trying to set up something that is child safe/friendly. If that’s the case, perhaps there are other solutions which will work better for you, such as child safe DNS service from OpenDNS (free options, but also a $20 year option for more features) https://www.howtogeek.com/79998/protect-your-kids-online-using-opendns/

I still want to setup my own proxy server
And
Still want to try work with Linux system

I got the computer case that I want to use for proxy server

Please help me out

Setting up the proxy server

I would love to help you, but I have never set up a proxy myself. It’s unclear if anyone else here on the TWiT forums will have the necessary experience to help you either. You may have to head over to Reddit and find a group there who knows Squid better. I’ll leave you with this Google search to see if that is helpful.

Also, I came across a tutorial, I have no idea if it will work better for you or not, so all I can say is you may need to “clean up” and try it. It definitely does things differently that what you were previously trying. Tutorial on how to setup a squid proxy with authentication. · GitHub
as well as this Stack Overflow question/answer: How to set up a squid Proxy with basic username and password authentication? - Stack Overflow

I had a spare 10 mins so i installed squid on a test box and it woks with the default config for me by simply uncommenting the line below in /etc/squid/squid.conf

#http_access allow localnet

This gives me full internet access from my laptop via the squid proxy, but without needing a password. Is the issue that you want to put a password in to access the internet ? Or is the issue that it is asking for a password but you dont want one ?

I also got it authenticating using the guide you were following but with one modification.

auth_param basic program /usr/lib/squid3/basic_ncsa_auth /etc/squid/passwords

should be

auth_param basic program /usr/lib/squid/basic_ncsa_auth /etc/squid/passwords

e.g. not /squid3/

I also commented back out the line in my message above ( http_access allow localnet), then when I reload the config with:

sudo squid -k reconfigure

I get asked for the username and password created in the guide above. Once I enter that, I get internet access.

Here’s my squid.conf - squid.conf - Pastebin.com

Thanks for all the help with proxy server

But I’m still not getting any luck with it

I will be leaving proxy server for in the future to work on and off

Hopefully I will get it working

Thanks again for all your help